Execute Powershell script

Mar 4, 2011 at 11:25 AM

Hei. Tnx for sharing the pack.

I have managed to get everything working except the powershell part. Im not sure what i have done wrong, tested and tested. But i keep getting the error Object reference not set to an instance of the object. SP2010 and win2008 r2. Anyone have any idea what im doing wrong?

Coordinator
Mar 4, 2011 at 6:59 PM

Hi,

I guess you checked the documentation at http://ilovesharepoint.codeplex.com/wikipage?title=Execute%20PowerShell%20Script%20Action&referringTitle=Workflow%20Actions%20for%20SharePoint%20Designer%202010

Please take a look to the SharePoint ULS log and provide further information.

Bye, Christian

Mar 5, 2011 at 10:55 AM
Edited Mar 5, 2011 at 10:58 AM

Hei, tnx for the fast reply. Yes, I followed the documentation provided in that link, unless i have misunterstood some part of it. 

The log shows me the following when I run a worklfow with Execute Powershell:

03/05/2011 03:43:17.41 w3wp.exe (0x0DC0)                       0x3540 Project Server                 Project Server Workflow       4wz8 Medium   Entering BeforeWorkflowRun for workflow: InstanceId = 8817b172-74e1-4889-9a19-fe360ea8e2cc 906a8b85-c52a-49fe-bcbc-03fa7e6038ae

03/05/2011 03:43:17.59 w3wp.exe (0x0DC0)                       0x3540 Unknown                       iLove SharePoint Workflow     0000 Unexpected Object reference not set to an instance of an object. 906a8b85-c52a-49fe-bcbc-03fa7e6038ae

03/05/2011 03:43:17.65 w3wp.exe (0x0DC0)                       0x3540 Project Server                 Project Server Workflow       4wzc Medium   Entering AfterWorkflowRun for workflow: InstanceId = 8817b172-74e1-4889-9a19-fe360ea8e2cc 906a8b85-c52a-49fe-bcbc-03fa7e6038ae