SPD Actions 1.0 Do not appear in SPD after Deploy..

Jan 21, 2009 at 5:00 AM
Hi Christian:

Thank you for offering this project on codeplex. This will be very useful. I am having the same problem as the user today. I deploy the solution and edited the web.config file fine but when I open up SPD I can see the actions are there but when I click on any of the iLoveSharepoint actions they do not appear in the field. Seems like something is missing in my install or ? Please let me know if you can help. Great Work!

Best Regards,

Chris

Wss on Server 2008/ English
Coordinator
Jan 21, 2009 at 4:26 PM
Hi Chris,

1. Ensure that you have the following entry in the web.config:
<authorizedType Assembly="iLoveSharePoint.Activities, Version=1.0.0.0, Culture=neutral, PublicKeyToken=eba025cae8366a95" Namespace="iLoveSharePoint.*" TypeName="*" Authorized="True" />
2. Ensure that you found the iLoveSharePoint.Activities dll (Public Key: eba025cae8366a95, Version 1.0.0.0)  in the global assembly cache (C:\windows\assembly)
3. Do an iisreset
4. Restart SharePoint Designer

Let me know if the problem still persists...

Bye, Christian
Jan 21, 2009 at 5:07 PM

Hi Christian:

Thanks for the reply. I have checked the above and all are correct but the problem still persists. When you try to add the action from the activities list nothing happens and it remains blank. Please let me know if there is anything additional I can do to help. It will be great to get this working for everyone...

 

Thanks--Chris

Coordinator
Jan 21, 2009 at 5:28 PM
Edited Jan 21, 2009 at 5:29 PM
Hi Chris,

in most cases this is related to the web.config. Please double check that the setting persist in the web.config of the application you want to use it (e.g. C:\Inetpub\wwwroot\wss\VirtualDirectories\80\web.config for port 80) and check that there isn't any unintended whitespace in any attribute. IISRESET and SharePoint designer restart is also important.

Furthermore you can check the existence of the file %commonprogramfiles%C:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\12\TEMPLATE\1033\Workflow\iLoveSharePoint_Activities_EN.ACTIONS. Within the file the assembly attributes have to match the assembly in the GAC (Assembly="iLoveSharePoint.Activities, Version=1.0.0.0, Culture=neutral, PublicKeyToken=eba025cae8366a95").

If this all matches, your configuration is right. The feature simply copies the dll to the GAC and the iLoveSharePoint_Activities_EN.ACTIONS to the appropriate location.
Last idea restart your server.

Really hope we get it take off...

Bye, Christian


Feb 10, 2009 at 8:37 PM
Hi Christian,

I have the same problem. I've checked all your suggestions, but I still cannot get the Actions to appear in my Workflow. I've also restarted my server.

I'm using a Norwegian version of SharePoint.

I saw that the file was named C:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\12\TEMPLATE\1033\Workflow\iLoveSharePoint_Activities_EN.ACTIONS

Does this mean that it will only show up in the English version ?

Could I simply rename it to iLoveSharePoint_Activities_NO.ACTIONS to make it show up in english on my Norwegian installation ?


Kay-Christian Wessel
Feb 10, 2009 at 8:44 PM
I solved it !

I renamed the file to iLoveSharePoint_Activities_NO.ACTIONS and put it in this folder : C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\1044\Workflow
since I am running the Norwegian version.
Feb 13, 2009 at 4:04 AM
Hi Christian:

Sorry for the late reply. Was hard to set aside some testing/config time for this. I was able to get this working as there was an error, as you suggested, in my web config. Just a simple copy/paste issue that was hard to spot. I am anxious to get testing tomorrow to see the functionality!

Thank you very much for your project and help!
Chris 
Aug 5, 2009 at 7:33 PM
Edited Aug 7, 2009 at 6:41 PM

Hi Christian:

I have the same issue of the "I don't get the designer rules. When I choose an ILoveSharePoint activity, no designer rule is shown where I can configure my properties".

I have deployed your solution in Windows 2008 server with iis7. There is no port 80 in this server. there were two dirctrories of 3703 and 25950!

I am not sure in which one I should go and I tried both. any how I see the action in sharpoint designer, just when I click on it, the rule is not there.

I see the file in GAC with the right token. I did the iis many times. and restarted the server twice.

still not there.

Can you please help.

Thank you very much for your time and the great action!

Aug 7, 2009 at 9:52 AM

Hi,

i have the same problem as Roxymoon,

the soluction i found:

in web.config replace <authorizedType Assembly="iLoveSharePoint.Activities, Version=1.0.0.0, Culture=neutral, PublicKeyToken=eba025cae8366a95" Namespace="iLoveSharePoint.*" TypeName="*" Authorized="True" />

for <authorizedType Assembly="iLoveSharePoint.Activities, Version=1.0.0.0, Culture=neutral, PublicKeyToken=eba025cae8366a95" Namespace="iLoveSharePoint" TypeName="*" Authorized="True" />

i just removed ".*" in the namespace and works for me. Sorry bad english

Aug 7, 2009 at 5:30 PM

thank you fanfarra.

But your suggestion did not work for me.

I deployed it in Dev. server 2003, and it worked perfectly (with .*) but in production server 2008 i don't see the designer rule when I select "create a site".

any other other suggestions.

 

Sep 2, 2009 at 12:27 AM

Ok. I finally found the issue.

In our server 2008, there is no port 80. and the other two ports are not the right port.

I used the IIS counsel to find the right port.

  1. Open the IIS console.
  2. Find the web site that is your SharePoint web under the "Web sites" node and select it.
  3. Right click and choose "Open".
  4. In the folder window, open the web.config file.

Now It is working.

Jan 21, 2011 at 6:02 PM

Hi Christian,

Excellent solution!! I was able to deploy this on SharePoint 2010. Quick question though:

I can see the workflow running successfully, but no site is actually getting created. Below are the values I am inserting:

URL: PDRSite1
Title: PDR Site1
Description: Product Development Request Site
Template: pdrsite.stp (I created a custom template)
Inherit Permissions: Yes
Store new site URL in Result
Language: 0

What did I miss? I am almost there just need a little help

Thanks again for this excellent solution

Snehal H.Rana
SharePoint Consultant

Jan 24, 2011 at 7:46 PM

Hi Christian,

Any update on my question? Let me know

Thanks,
Snehal H.Rana
SharePoint Consultant

Coordinator
Jan 26, 2011 at 5:50 PM

Hello Snehal,

your parameters looks fine. When the workflow runs successfully the site should be created at ~weburl/PDRSite1

The link will not be added to the top link bar automatically.

Bye,

Christian

Jan 28, 2011 at 9:58 PM

Hi Christian,

Unfortunately, it doesnot. I was hoping if this feature can be enhanced to create a list called "PDR" automatically with columns predefined. Here is my scenario:

I want a workflow to trigger from a custom list. This workflow should create a site automatically. As soon as this new site is created, there should be a new list in this newly created site with similar columns as the original site.

BTW, I tried using STS#0 as the Template and it works great. It just does not accept custom template.

Once again thanks for your response

Thanks,
Snehal H.Rana
SharePoint Consultant

Feb 3, 2011 at 2:34 PM

Any update?

Coordinator
Feb 6, 2011 at 6:57 PM

You have to use a custom template. Custom templates should works. You have to use the name of the template plus extension e.g. mytemplate.stp (template have to be in gallery of the site that hosts the workflow).

Bye, Christian

Feb 7, 2011 at 9:59 PM

The site template is stored as .wsp and not .stp in Solutions Gallery. I just entered pdrsite2.wsp but still no luck. Any idea?

Coordinator
Feb 8, 2011 at 8:03 PM

Hi,

means you are using SP2010. You can use PowerShell to get template name:

PS> (get-SPWeb http://server/sites/a).GetAvailableWebTemplates(1033)

1033 is the language code

Bye Christian

Feb 11, 2011 at 6:49 PM

EXCELLENT!! you just made my day Christian. You rock!! It works like a charm!

I just used the following command:

(get-SPWeb http://server/sites/a).GetAvailableWebTemplates(1033) |Format-List >c:\tmplt1.txt

Gives me exact ID for my custom template.

Can't thank you enough

Snehal H.Rana

 

Apr 4, 2011 at 9:07 PM

Will this work on a 2007 moss server I have gone through every step, in this thread and yet I cannot find why the actions will display and yet not add to my workflows?

Everything is correct Gac, Web.config, Solutions everything just will not add to a workflow from the actions menu.

Any Help would be great.

Apr 3, 2013 at 12:16 PM
Can anyone say if this is compatible with SharePoint 2013 please? I can see the custom action in SharePoint Designer, but no rules are available!!
  <WorkflowService Assembly="ILoveSharePoint.Workflow.Activities, Version=2.0.0.0, Culture=neutral, PublicKeyToken=428fb66db95070b0" Class="ILoveSharePoint.Workflow.Activities.WaitForExternalEventService" />

  <authorizedType Assembly="ILoveSharePoint.Workflow.Activities, Version=2.0.0.0, Culture=neutral, PublicKeyToken=428fb66db95070b0" Namespace="ILoveSharePoint.Workflow.Activities" TypeName="*" Authorized="True" />
Any ideas welcome!!

Randine
Apr 3, 2013 at 1:24 PM
Hi randineperry,

I have installed Sharepoint 2013 also here, deployed the WSP, the changed keys in WebConfig NameSpace and Assembly, but the stock does not appear when I create a WorkFlow.
What have you done to show the actions of the solution in Sharepoint Designer?
Apr 3, 2013 at 1:26 PM
The tag must be included in WorkflowService WebConfig also for Sharepoint 2013?
Apr 5, 2013 at 2:45 PM
Hi WebMasterjy,

The web part must be installed with the CompatabilityLevel parameter when installing the wsp file using powershell command : Install-SPSolution

Value Result
14 Installs solution to 14 directories only
15 Installs solution to 15 directories only
“14,15” Installs solution to both 14 and 15 directories
“AllVersions” or “All” Installs solution to both 14 and 15 directories
“OldVersions” or “Old” Installs solution to 14 directories only
“NewVersion” or “New” Installs solution to 15 directories only

I hope this is of help, I'm still having issues using the rules for the actions though.

Randine
Apr 5, 2013 at 2:46 PM
Hi WebMasterjy,

The web part must be installed with the CompatabilityLevel parameter when installing the wsp file using powershell command : Install-SPSolution

Value Result
14 Installs solution to 14 directories only
15 Installs solution to 15 directories only
“14,15” Installs solution to both 14 and 15 directories
“AllVersions” or “All” Installs solution to both 14 and 15 directories
“OldVersions” or “Old” Installs solution to 14 directories only
“NewVersion” or “New” Installs solution to 15 directories only

I hope this is of help, I'm still having issues using the rules for the actions though.

Randine
Apr 8, 2013 at 11:55 AM
Hello All,

Does anyone have a solution for SharePoint 2013 to display the rules for the selected custom actions please? Urgently urgently would very much appreciate the effort in responding.


Would like to hear from you.


Randine
May 30, 2013 at 9:27 PM
Hi I made the installation on 2013 following the instructions by randineperry and the actions show on SPD 2013 but when you try to add the actions to the workflow nothing happens. Have any one successfully installed Advanced Workflow Actions on 2013?

Kind Regards