Not working when tried the operation "add users to Group" action using Impersonation step

Nov 13, 2013 at 10:04 AM
I have installed the wsp file using poweshell in sharepoint foundation 2010, activated the feature in Site collection and now I'm able to see the workflows actions on SharePoint designer.

I tried to do an operation with on workflow using "add users to Group" action:
  • I see there is no selection of Group name, just copied the name group there.
  • Added a user also.
  • Run the workflow once the record is created
  • Workflow is failed with error System Account
  • Checked that the user is not added in the group
Do you have any idea why it's not working in SharePoint foundation 2010. Are you sure the solution is ok now. Seems like it's now working, could you please upload the workable wsp file in that case.
Nov 21, 2013 at 3:09 AM
I am also finding that "Add users to Group" action" throws a rather generic error "MyWorkflowName failed to run".

I'm using this action on SharePoint Server 2010 Enterprise and the account I used to create the workflow and impersonation step is both Site Collection admin and Site Owner.

The strange thing is that it actually adds the user to the relevant group, but the error is not something one wants to see in the logs.