1
Vote

I love SP Sandboxed Create site action

description

I am continuing developing our SP2010 site and have a need to automate the creation of subsites following the entry into a list.

The Sandboxed solution has deployed and activated successfully and I get the option when using an impersonation step with designer of which again I complete and publishes without error.

When I run it just says error in the work flow status.

I have checked permissions and tried publishing / running with the admin account with same results.

Basically I need to create a sub site based on the standard "Team Site" template.

A great place to start would be to find out more info on the error but I am probably missing the obvious as I cant see where.

Thanks

comments

melissafre49 wrote Apr 30, 2014 at 8:50 PM

It is a little finicky, but will work if you...:

do not use the function (fx) button for the siteName or Description. Use the "..." to build a string and add your variable there.

Do not create your own output variables. Leave them the way they are when you first add the activity

For basic Teamsite use this value:

STS#0

swithers25 wrote May 1, 2014 at 8:36 AM

Thank you Melissafre49, much appreciate your help. I have followed the instructions but sadly the same results. I have made sure that my workflow also matches that of the successful example on the web site. All I get is an error has occurred, no code, no info. My only option to manually terminate. I am leaning towards a permission issue here as I am aware the impersonation step runs as the published user. However this has been done with the administrator account with full control. The error in the workflow history does reference the system account but that also has full control. Looking at the site this should be straight forward but if anyone has any tips on troubleshooting or where I can gain more info on the error that would be great. Thank you.