Sharepoint 2010 and lookup with picker

Apr 1, 2010 at 9:22 AM

hi guys,

 I am using sharepoint 2010 beta version. this lookup with picker doesnt work with sharepoint 2010. I had funcionality in Sharepoint 2007 MOSS, where I used lookupwith picker and it was very useful for me. Can You give me some tip on it?

It tells me in log of Sharepoint 2010:

System.NullReferenceException: Object reference not set to an instance of an object.    at Microsoft.SharePoint.ApplicationPages.LookupFieldEditor.InitializeWithField(SPField field)     at ASP._controltemplates_lookupfieldwithpickereditor_ascx.InitializeWithField(SPField field) in c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\CONTROLTEMPLATES\LookupFieldWithPickerEditor.ascx:line 180     at Microsoft.SharePoint.ApplicationPages.FieldCustomizationPage.OnLoad(EventArgs e)     at Microsoft.SharePoint.ApplicationPages.FieldNewPage.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 44f945ac-bea4-4c59-b1cc-8f046c4d540c


Thanks in advance for any helpful tip.

May 11, 2010 at 11:21 AM

Hi blsakmiso,

I got the same problem with the RTM and the same error. I tried everything and i do not get to the control works.

Have you got any new or workarround about this error?


Thank you


May 11, 2010 at 12:11 PM


have you tried to upgrade to Picker 2010

Bye, Christian

May 11, 2010 at 12:18 PM

I have finish now to check it

Thank you cglessner.

The new version for SP2010, works fine!



May 19, 2010 at 9:03 AM
Edited May 19, 2010 at 9:20 AM


Great work, only one problem: When using the field in combination with a docx file, the selected value is not being saved. I uploaded a txt file to the same library, and the field is working as expected using that filetype.


update: only seems to happen when multiple values can be selected

May 19, 2010 at 11:04 AM


confirmed, very strange, maybe problem with Office property promotion. I've to do further investigations....

Bye, Christian

May 19, 2010 at 9:16 PM


could you please check the latest build. After deploy you have to go the field settings and save the field again.

Bye, Christian

May 25, 2010 at 7:27 AM

Tested it, and it works